Esta consulta es de hace 2 años. Tenga eso en cuenta.
info_e09ce6
info_e09ce6
España

Plugin: servicios ¿este error me lo da solo a mi? lo he...

Plugin: servicios

¿este error me lo da solo a mi?

lo he visto en: /index.php?page=admin_info
Error al ejecutar la consulta 0: Column 'codserie' cannot be null. La secuencia ocupa la posición 18
27-10-2018 01:46:58   02-11-2018 17:23:02   85   [pcrednet]
Me ocurre igual que a tí. Lo he solucionado seleccionando los clientes con serie predeterminada (null) y asignándole la serie 'A' (que, en mi caso, es la serie predeterminada)

Slds.
Gracias por contestar, he cambiado la serie a todos como has puesto y ya no me da error en Información del sistema, pero ¿Hay alguna manera de que se asigne siempre la serie A a los clientes nuevos?
Alguno de los plugins que tenéis activados no está haciendo bien su trabajo. Si el cliente no tiene seleccionada una serie, se usa la de la empresa.
¿Cuál es la página que genera ese error?
La pagina es: ventas_servicios y estas son las lineas que encuentro con "codserie" en el archivo "ventas_servicios.php"
Line 33: public $codserie;
Line 112: $this->codserie = '';
Line 211: if (isset($_REQUEST['codserie'])) {
Line 212: $this->codserie = $_REQUEST['codserie'];
Line 212: $this->codserie = $_REQUEST['codserie'];
Line 358: if ($this->codserie != '') {
Line 359: $sql .= $where . "codserie = " . $this->agente->var2str($this->codserie);
Line 359: $sql .= $where . "codserie = " . $this->agente->var2str($this->codserie);
Line 459: $this->servicio->codserie = $this->empresa->codserie;
Line 459: $this->servicio->codserie = $this->empresa->codserie;
Line 500: . "&codserie=" . $this->codserie
Line 500: . "&codserie=" . $this->codserie
Lo siento pero no consigo reproducir ese fallo.
Tengo clientes con serie null y creo servicios y modifico sin problemas.
El documento de venta en servicios hace bien su trabajo, al menos eso veo yo.

No puedo decir más.
A mí tampoco se me reproducía el error, hasta que, en mi instalación de pruebas, he modificado codserie a null en todos los clientes. Adjunto capturas.

image
Aquí la consulta 20

image
Parece que el error viene de servicios_contratados, según indica información del sistema

Si alguno de los clientes que tienen contrato de mantenimiento, también tiene codserie = null, se produce ese error.
Gracias, Visto.
He reproducido el error y ya está solucionado. Estaba en servicios_contratados, como bien indicabais.
Acabo de lanzar el update, os saltará en breve.
Gracias por reportar, y gracias por la información!!!
cierro


Copyright (c) 2013-2020 FacturaScripts