Esta consulta es de hace 3 años. No tome esta información como actualizada. Si tiene problemas con FacturaScripts, consulte la sección ayuda o la sección contacto
eclipsepresas_f74d39

Plugin: prestashop_micro se queja que tengo que instalar...

eclipsepresas_f74d39   España   11-10-2018 09:37:21   11-10-2018 16:49:26   183   [NeoRazorX]
Plugin: prestashop_micro
se queja que tengo que instalar curl, pero creo que lo tengo funcionando bien, he probado a rm la carpeta prestashop_micro de plugins y volver a instalar y seguimos en las mismas

Plugins relacionados

Plugin prestashop_micro
esto dice el plugin

imagen
y esto mi phpinfo()

imagen
y algo mas

imagen
Hola, la comprobación que hace el plugin no tiene vuelta de hoja:
if (!function_exists('curl_init')) {
$this->new_error_msg('No se encuentra la extensión php-curl, tienes que instalarla.');
}
Si muestra el mensaje es que curl no está disponible.

Los motivos, en base a mi experiencia, son:
- php-curl está instalado, pero no se ha reiniciado apache.
- php-curl se ha instalado en otro servidor que no es en el que está facturascripts.
- php-curl se ha instalado para una versión de php que no es la que se está ejecutando en el servidor.
probaré gracias!
la funcion no deveulve nada (página en blanco) o no se hacerla funcionar

<?php
if (!function_exists('curl_init')) {
$this->new_error_msg('No se encuentra la extensión php-curl, tienes que instalarla.');
}
?>


curl está instalado (al menos eso me dice apt)
apache ha sido reiniciado varias veces (sudo service apache2 restart) incluso he reiniciado el server (una rpi)
me da la sensacion que curl no esta habilitado de algun modo pero en /etc/php/7.0/apache2/conf.d/20-curl.ini esta descomentada la línea :

; configuration for php curl module
; priority=20
extension=curl.so


tambien igual en cli/conf.d/20-curl.ini

voy a salir loco
leyendo la funcion deduzco que si está disponible esa funcion es porque está instalada y por eso sale una pagina en blanco, probaré a darle un else a ver que dice
nada de eso mas sencillo:
<?php

if (!function_exists('curl_init')) {
echo 'No se encuentra la extensión php-curl, tienes que instalarla.';
}

?>

efectivamente dice no está instalada (no disponible vaya) pero ya no se que mas hacer
He migrado a otro server, reinstalaré este y lo volveré a traer
CERRADO
¿Problemas con FacturaScripts?
Si tiene problemas con FacturaScripts consulte la sección ayuda o la sección contacto




Copyright (c) 2013-2021 FacturaScripts